Web Service Client stage returns empty xml file

Dedicated to DataStage and DataStage TX editions featuring IBM<sup>®</sup> Service-Oriented Architectures.

Moderators: chulett, rschirm

Post Reply
hobocamp
Premium Member
Premium Member
Posts: 98
Joined: Thu Aug 31, 2006 10:04 am

Web Service Client stage returns empty xml file

Post by hobocamp »

This is a rather odd problem I believe.

The output I'm getting from my webservice call is an empty xml file (containing only a single line feed). I'm getting this result with a couple of different web service calls. Job design is simple - WS Client ---> File (and for "File", I've tried both sequential and XML Output stages).

Now, I know that I should have non-empty results for a couple of reasons -
-when pasting the soap request envelope copied from the log in "Trace" mode into SoapUI, I get the expected results.
--Also, in that same log file (in "Trace" mode), the XML Response envelope shows the expected xml data returned.
But somehow that data isn't making it out to my file.

I've tried calling these servives in both server and EE jobs, with the same results. (In the EE job, I also added a Peak stage after the WS Client stage, and the Peak shows empty as well - it simply displays the column name.)

Has anyone else run into this before? I also have a PMR open with IBM, but they haven't been able to provide much yet.

Thanks.
Tom
eostic
Premium Member
Premium Member
Posts: 3835
Joined: Mon Oct 17, 2005 9:34 am

Post by eostic »

If you are seeing the output in the "Trace" of the DataStage Log, then it may simply be that the output payload is too complex for the WSClient Stage....

Change your WSClient Stage so that its output link has one giant column (like a longvarchar with a length of (say) 99999). Put a single "/" in the Description... but also look on the "message tab" for the output link.....select "user defined column" in the pull down.

Send that column to a sequential file with no formatting. If in Server Job, use 000 for delimeter and for quote character... if EE, use "NONE" for both settings.

Ernie
Ernie Ostic

blogit!
<a href="https://dsrealtime.wordpress.com/2015/07/29/open-igc-is-here/">Open IGC is Here!</a>
Post Reply