DSXchange: DataStage and IBM Websphere Data Integration Forum
View next topic
View previous topic
Add To Favorites
Author Message
dsexplorer



Group memberships:
Premium Members

Joined: 16 Apr 2008
Posts: 23
Location: Prague,Cz
Points: 207

Post Posted: Wed Jul 18, 2018 12:08 am Reply with quote    Back to top    

DataStage® Release: 11x
Job Type: Parallel
OS: Unix
Since upgrade of ETL we are facing issue with asian UTF8 characters loading to Teradata.
"?" characters are inserted in tables instead.

What I tried to resolve the issue
- Change utf8 to utf16 (Teradata is UTF16 internally)
- Use original obsolete mLoad stage in DS 11
- Use new TD connector stage

No success. When the same job’s output is pointed to a flat file (any encoding) the file contains valid chinese chars. Hence the issue is in TD connection from DS 11.

Can you advise please?

_________________
Regards
DSExplorer
PaulVL



Group memberships:
Premium Members

Joined: 17 Dec 2010
Posts: 1245

Points: 8171

Post Posted: Wed Jul 18, 2018 9:23 am Reply with quote    Back to top    

I would start with confirming the character set on the table with your TD DBA.

I would then ensure that your TD connector stages are set to that character set.

I would also ensure that your DataStage JOB is set to that character set.

UTF16 is the most likely candidate since you are using a double byte character set for chinese.

You might also have to change your Windows Character set if you want to do a "View Data" activity.
Rate this response:  
Not yet rated
Display posts from previous:       

Add To Favorites
View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Powered by phpBB © 2001, 2002 phpBB Group
Theme & Graphics by Daz :: Portal by Smartor
All times are GMT - 6 Hours