DSXchange: DataStage and IBM Websphere Data Integration Forum
View next topic
View previous topic
Add To Favorites
Author Message
Naren12345babu



Group memberships:
Premium Members, Heartland Usergroup

Joined: 06 Jan 2016
Posts: 68
Location: Bangalore
Points: 842

Post Posted: Wed Mar 21, 2018 5:54 am Reply with quote    Back to top    

DataStage® Release: 11x
Job Type: Parallel
OS: Unix
HI

I am sending a PDF attachment using Notification activity in the sequence job.

But along with PDF attachment, I am receiving an Empty File attached with name ATT00001.txt

I went through one of the Posts where it was written that there is nothing to do with datastage, it is Microsoft Xchange settings that create this file.

However, When I send some attchment from unix directly, then this extra file is not getting attached.

Any solution to avoid this extra file attachment.

_________________
Thanks
Naren Babu Ch
chulett

Premium Poster


since January 2006

Group memberships:
Premium Members, Inner Circle, Server to Parallel Transition Group

Joined: 12 Nov 2002
Posts: 42765
Location: Denver, CO
Points: 220367

Post Posted: Wed Mar 21, 2018 7:50 am Reply with quote    Back to top    

What utility did you use at the UNIX command line?

My advice if you don't find a solution... don't worry about it. They are easily ignored. Wink

_________________
-craig

Research shows that 6 out of 7 dwarves aren't happy
Rate this response:  
Not yet rated
DSUser2000
Participant



Joined: 20 Oct 2009
Posts: 41

Points: 499

Post Posted: Mon Apr 16, 2018 9:34 am Reply with quote    Back to top    

In your Server/Projects/<Projectname> folder, you will find a file called "dssendmail_template.txt" (you should call it "dssendmail.txt" when you use it so that it survives patches/upgrades). This is the script that is called by datastage when a mail is sent. It is more or less a normal unix script so you can use this to debug your error (you can use "echo" to put out messages to the datastage sequence log or you can also output to the filesystem!) and fix it Very Happy
You will find detailed documentation about how to use it inside the file.
Rate this response:  
ArndW

Premium Poster
Participant

Group memberships:
Premium Members, Inner Circle, Australia Usergroup

Joined: 16 Nov 2004
Posts: 16318
Location: Germany
Points: 92566

Post Posted: Tue Apr 17, 2018 3:25 am Reply with quote    Back to top    

I vaguely recall having had this problem once as well. I recall it was when using Microsoft Outlook Servers and it was a setting there which caused this. Are you using Outlook?

_________________

Image
Rate this response:  
Not yet rated
chulett

Premium Poster


since January 2006

Group memberships:
Premium Members, Inner Circle, Server to Parallel Transition Group

Joined: 12 Nov 2002
Posts: 42765
Location: Denver, CO
Points: 220367

Post Posted: Tue Apr 17, 2018 7:07 am Reply with quote    Back to top    

I would assume so as it is a fairly notorious Outlook / Exchange server issue. Wink

_________________
-craig

Research shows that 6 out of 7 dwarves aren't happy
Rate this response:  
Not yet rated
Display posts from previous:       

Add To Favorites
View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Powered by phpBB © 2001, 2002 phpBB Group
Theme & Graphics by Daz :: Portal by Smartor
All times are GMT - 6 Hours