DSXchange: DataStage and IBM Websphere Data Integration Forum
View next topic
View previous topic
Add To Favorites
Author Message
skathaitrooney
Participant



Joined: 06 Jan 2015
Posts: 96

Points: 877

Post Posted: Fri Jan 19, 2018 7:01 am Reply with quote    Back to top    

DataStage® Release: 11x
Job Type: Parallel
OS: Unix
Hello Experts,

Wondering if i can get an insight from the IGC gurus.

I am trying to build lineage for datastage jobs in IGC.
I know i have to upload the environment variables (ProcessEnvVariable.sh), do a data connection mapping and do a Detect Lineage Relationship for an end-to-end lineage.

Everything works as expected but:
I get 2 entries for the job in IGC in Job Usage Information -
1. with the environment variables
2. With the actual value of the variables

Ideally, after processing the environment variables and the data connection mapping, the actual env variables should vanish and they should be replaced by the actual values.

But i see both of them.

I did search a lot for the solution, but nothing worked out for me.

I just wish if someone knows how to fix it.
eostic

Premium Poster



Group memberships:
Premium Members

Joined: 17 Oct 2005
Posts: 3773

Points: 30298

Post Posted: Fri Jan 19, 2018 2:32 pm Reply with quote    Back to top    

Hard to say without looking at it directly, but if you are successfully collecting Operational Lineage (when you say "actual" values), then it is possible that you don't have any default values for yo ...

_________________
Ernie Ostic

blogit!
Open IGC is Here!
Rate this response:  
Not yet rated
Display posts from previous:       

Add To Favorites
View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Powered by phpBB © 2001, 2002 phpBB Group
Theme & Graphics by Daz :: Portal by Smartor
All times are GMT - 6 Hours