DSXchange: DataStage and IBM Websphere Data Integration Forum
View next topic
View previous topic
Add To Favorites
This topic has been marked "Resolved."
Author Message
arvind_ds
Participant



Joined: 16 Aug 2007
Posts: 428
Location: Manali
Points: 4204

Post Posted: Fri Oct 21, 2016 2:34 pm Reply with quote    Back to top    

DataStage® Release: 9x
Job Type: Parallel
OS: Unix
Hi Experts,

We are experiencing slowness while importing oracle table definitions by using InfoSphere Asset manager(IMAM). We are using infosphere information server 9.1.2 version on AIX 7.1 platform. We have recently upgraded oracle application databases from 11g version to 12c. Please note that our metadata repository is still at oracle 11g version. We know that InfoSphere Information server 9.1.2 does not support metadata repository on oracle 12c version.

Problem Description : When we try to import oracle 12c table definitions through IMAM, it is taking long time to do the import. The same table definitions when imported in the past from oracle 11g application database, were NOT taking that much amount of time to import into staging database.

Example : When IMAM 9.1.2 is used to import 10 table definitions from oracle 11g database, it was taking hardly 10 minutes to get the table definitions imported onto the staging database. Now after migrating the same oracle application database from 11g to 12c, the same set of table definitions(10 in this case), is taking close to 2 hours to get imported onto the same staging database. We have not done any changes across infosphere platform as such during this oracle DB migration.

In addition to this, whenever we increase the number of table definitions count(to be imported through IMAM from oracle 12c database), the IMAM import just hangs.

Please share your inputs on how to get this issue resolved. Many thanks !

_________________
Arvind
arvind_ds
Participant



Joined: 16 Aug 2007
Posts: 428
Location: Manali
Points: 4204

Post Posted: Mon Nov 28, 2016 3:05 am Reply with quote    Back to top    

Problem resolved. The performance issues were encountered due to less capacity on the underlying oracle(12c) database server. Nothing wrong with InfoSphere IMAM tool as such.

_________________
Arvind
Rate this response:  
Not yet rated
Display posts from previous:       

Add To Favorites
View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Powered by phpBB © 2001, 2002 phpBB Group
Theme & Graphics by Daz :: Portal by Smartor
All times are GMT - 6 Hours